読者です 読者をやめる 読者になる 読者になる

ハイパーニートプログラマーへの道

頑張ったり頑張らなかったり

Android ADT Bundle r22.6 -> 22.3に戻そうとして失敗 -> 入れ直すまで

なんかr22.6系だといろいろ具合が悪いようで、ダウングレードしたいなと。

22.6->22.3へ

Android SDK

http://detail.chiebukuro.yahoo.co.jp/qa/question_detail/q11122189786

上記記事を参考に

http://dl.google.com/android/android-sdk_r22.3-macosx.zip

Mac用の22.3sdkをダウンロード>作業用フォルダで展開しておく。
ADT Bundleフォルダのsdkフォルダ>toolsフォルダを削除。
展開しておいた22.3のtoolsフォルダをそこに移動。

ADTプラグイン

http://note.chiebukuro.yahoo.co.jp/detail/n262323
ここの記事を参考にADTのダウンロードURLを22.6.0を22.3.0に書き換え>ADT-22.3.0.zipをダウンロード

(一応DL用URLも) http://dl.google.com/android/ADT-22.3.0.zip

ADTについて>Install Details>22.6になっているものをアンインストール

f:id:noriyo_tcp:20140513155230p:plain

でもよく見てみると、22.6も残ってる?
そこでよせばいいのに、えいや!と全部削除したら・・・Eclipse立ち上がらん(T_T)

そんなわけでまるっと入れ直しです。。。
既にあったeclipse,sdkフォルダなどを削除しておいて・・・。

ADT Budnle入れ直し

こちらを参考に
http://techacademy.jp/magazine/1531

ADT Bundle DLして>上記記事ではeclipseフォルダ配下にsdkフォルダを入れちゃって、それをApplication配下に置いてます。
そこからEclipse起動>Help>Install New Software>Add>ここでArchiveを選んで、先ほどDLした、ADT-22.3.0.zipを指定

f:id:noriyo_tcp:20140513155349p:plain

22.3.0になっているようですな・・・。

Eclipse再起動の際に、sdkフォルダ見つからんよ! みたいに怒られるがとりあえずスルー

Locationの設定

SDK Locationを設定>記事では「環境設定>Android>SDK Location」から入ってるが、怒られたときのダイアログにPreference(だったかな?忘れたw)があったのでそこを開くと、ロケーション設定画面になる>eclipseフォルダ配下に置いたsdkフォルダを選んで設定

あとは、Window>Android SDK Managerでいろいろインストール
その際にSDKを26にアップデートしないように注意すれば良い、と。

Eclipseを再度入れ直した際、SDK Managerで確認したら22.3になっていたのでよかったのですが、もしかしたら22.6になっている可能性もある?
そのときは上記の、Mac用の22.3sdkをダウンロード>作業用フォルダで展開しておく。
ADT Bundleフォルダのsdkフォルダ>toolsフォルダを削除。
展開しておいた22.3のtoolsフォルダをそこに移動。
という作業をやらねばならんかもしれません。